Pro/Forums

Pro/Forums (http://forums.procooling.com/vbb/index.php)
-   Snap Server / NAS / Storage Technical Goodies (http://forums.procooling.com/vbb/forumdisplay.php?f=82)
-   -   Snap Server 4000 disk error. (http://forums.procooling.com/vbb/showthread.php?t=15277)

KarlCoot 02-20-2009 11:22 AM

Snap Server 4000 disk error.
 
Hi guys, am hoping for some help.

Got into the office this morning and one of our fileservers was dead. I restarted the machine and it looks like one (or all) of the disks are dead. Below is from the error log:

E File System Check : FSCK fatal error = 39 Disk 60000 20-2-2009 17:02:25
E File System Check : Bad state 0 for inode I=225417 Disk 60000 20-2-2009 17:02:25

These come after the disk status has been on 5% for a while (say 10 mins). I read somewhere that disk 60000 indicates that it's in RAID5 (which it is) but how do I find out if there is one particular disk causing the error?

We have another Snap Server 4000 out back so I could replace the disk like for like with no problems I'm just at a loss as to determine which one is toast!

Your help would be much appreciated!

Some more info for you:

Model Software Hardware Server # BIOS
4000 series 3.4.772 (UK) 2.2.1 502950 2.4.437

blue68f100 02-21-2009 08:18 AM

Re: Snap Server 4000 disk error.
 
If you give it enough time normally the front panel lights will tell you. Look in the log file it should give you a reference to what has failed. I would look prior to the reboot. Also do you have the colored ribbon cables or the play ones? This is critical as to reporting correctly. If colored your MB revision should be >v2. If not it will not report the error correctly. The colored ribbons have a wire cut in them.

The 5% area repersents a failed HD. But you do not want to start unplug things till you know which one has failed. Other wise you may loose the whole array. If you do not have the colored ribbons check your backup units and need be power down and change them. Don't worry about the check in process. If you do not have the colored ribbions it will not report the drive corectly and you may loose everything because it will show 2 HD have failed.

KarlCoot 02-23-2009 05:17 AM

Re: Snap Server 4000 disk error.
 
Not got any records of the earliest logs because I did reboot a few times on Friday causing the log to fill. I did run a check disk again though without it trying to fix errors (I saw it at 75% but might have got further). Then lost network activity so had to power off via the button on the front. Here's two new entries generated from the log because of that:

Call Stack :
$0011B652
$002D803E
$002475B2
$00247AD9
$002481F8
$00241EF6
$002422F7
$002385A0
$0023585F
$001041C3
================================
System 23-2-2009 10:28:42
F PANIC : General Protection Fault (#13) at $00247285
EAX=00020000 EBX=00000000 ECX=4620746E EDX=00000000
ESP=003F4D80 EBP=003F4D94 ESI=07368724 EDI=00020000 System 23-2-2009 10:28:42

Also, nothing indicated on the front panel in relation to any disks failing.

Ribbons cables are grey with a red border on each side.

blue68f100 02-23-2009 07:52 AM

Re: Snap Server 4000 disk error.
 
This indicates you have an early version of the 4000. These have problems reporting properly. You need to find the thread on 4000 not reporting correctly. The v3> have colored ribbons cables have a wire cut that is required for the 4000 to report correctly. It can be done to the older cables but it's a lot harder to locate the correct wire.

KarlCoot 02-23-2009 08:36 AM

Re: Snap Server 4000 disk error.
 
Thanks. Had a little search here and on google but no luck. Does anybody know any more on this "not reporting correctly" issue?

Thanks.

blue68f100 02-23-2009 02:50 PM

Re: Snap Server 4000 disk error.
 
You could have a power supply failing too. The 4000 are know to have weak PS. Since most person upgrade to the 7200rpm and higher capacity HD it over loads them on startup, inrush.

I would use the search feature on this site and start searching in the Snap treads for ribbon, 4000 and see if you can locate the thread. The post I think included photos showing the wire cut in the ribbon.

KarlCoot 02-27-2009 03:21 AM

Re: Snap Server 4000 disk error.
 
Thanks. Have had no luck searching for that thread so instead I'm just copying the data from our backups to another Snap Server we have (12000).

Out of interest though, it appears that some files are not copying across because the file name is too long. By my reckoning (counting existing subdirectories) the file name allowed is only up to 64 characters. There surely is a way to make this higher? The Snap 4000 definitely was higher.

Any ideas?

KarlCoot 02-27-2009 03:56 AM

Re: Snap Server 4000 disk error.
 
Quote:

Originally Posted by KarlCoot (Post 171084)
Thanks. Have had no luck searching for that thread so instead I'm just copying the data from our backups to another Snap Server we have (12000).

Out of interest though, it appears that some files are not copying across because the file name is too long. By my reckoning (counting existing subdirectories) the file name allowed is only up to 64 characters. There surely is a way to make this higher? The Snap 4000 definitely was higher.

Any ideas?

Answering myself here. ;)

Because I was using an OSX machine and AFP to mount the share on the 12000, the version of AFP on the snap is old and doesn't support more characters.

I'm using SMB to mount the share instead with no issues.


All times are GMT -5. The time now is 12:38 PM.

Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
(C) 2005 ProCooling.com
If we in some way offend you, insult you or your people, screw your mom, beat up your dad, or poop on your porch... we're sorry... we were probably really drunk...
Oh and dont steal our content bitches! Don't give us a reason to pee in your open car window this summer...