Pro/Forums (
-   Snap Server / NAS / Storage Technical Goodies (
-   -   Snap Server 12000 (

jtrue 08-13-2012 11:02 PM

Snap Server 12000
hey guys
I have a snap server 12000 ive been running for a couple years.
i started having trouble accessing some of the drives, in attempt to figure out what was going on i tried to log in to the admin page via the browser and could not connect to it.
i have tried the management software as well and it will not connect.
it shows up on the other computers but i can only access a couple drives.
i think the os has corrupted on me but i cant reinstall it because i cant connect via the admin page or from the management software.
can anyone help solve this without losing all my data?


jtrue 08-19-2012 03:59 PM

Re: Snap Server 12000
im still not having any luck with this.
im assuming its time to find a new nas unit but i was hoping the gurus would chime in and help me out.

Zavyre 08-20-2012 03:17 AM

Re: Snap Server 12000
I'm not really familiar with that unit ... and not quite a guru but ...

This is not a Guardian unit correct?
( and what version is it )

Is your front panel telling you anything?

So the web admin page will not load with the IP or the snapXXXXXX at all? Or you can see it but just can't login?

Does Snap Manager even see it? If it does and it's a guardian then I think you can update the OS from the Administer Servers menu selection without the need for the web interface. I'll have to check tomorrow.


it shows up on the other computers but i can only access a couple drives.
What setup is it in .. JBOD or raid 5 with multiple shares?

Do you by chance have any extra drives on hand?

blue68f100 08-20-2012 01:44 PM

Re: Snap Server 12000
Does the Snap Management utility see's the unit? If so, you may try to reload the OS through it.

Does that unit use the Flash HD to load the OS? If I recall there is a battery in those units somewhere.

What brand of HD's are in the unit?

Could have a PS issue too.

Andy is the HW guru but I don't know if he ever had a 12000.

jtrue 08-20-2012 08:37 PM

Re: Snap Server 12000
its a snap os and it does not even connect via the web browser it times out.
from the admin software it asks for a login and then times out once you put it in and hit enter.
the drives are set up with 1 and 10 mirrored and the rest are individual drives.
hope someone can help i really miss this thing on my network not to mention i have alot of stuff on it.

jtrue 08-23-2012 03:25 PM

Re: Snap Server 12000
the snap management utility sees it show it online but wont connect to it to do anything it asks for the login and times out.
it has western digital 80 gig drives.its a snap os so it does not use the drive to load the os.
the power supplies seem fine i even swapped them to see if it made a difference.
i replaced the fans in the power supplies 2 years ago and have had no problems until now.
i am really hoping someone can help me resurect this thing.

blue68f100 08-30-2012 01:24 PM

Re: Snap Server 12000
The SnapOS does not like to shut down improperly. All this does is corrupt the HD's and OS. The snap OS is subject to corruption end though it may be be in flash.

achapman 10-09-2012 05:08 AM

Re: Snap Server 12000
I have a 12000. Basically it is similar to a 4100 and all the troubleshooting procedures for a 4100 can be used. The one thing to note is that it won't run on the latest (i.e. last) versions of SnapOS unlike the 4100. Like the 4100 it is limited to 128Gb hard disks.

I would remove all your present disks and use a single new disk until you get it going again. Once it is up and running you can refit the original disks as they were.
It has been a while since I recovered a 4100 or 12000 so I can't remember the procedure, but I think it means doing a factory reset and possibly reflashing the unit.


gglobus 07-03-2013 12:20 PM

Re: Snap Server 12000
I am trying to format a replacement drive for one that went south. Is there a low level command that needs to be run on one of theses drive to put the right formatingon it. These ar seagate Baracuda drives exact same one that went bad.

achapman 07-03-2013 02:19 PM

Re: Snap Server 12000
No. One just uses the web administration interface to configure the disk for use. Any existing data or formatting will be overwritten. No pre-configuration is required, all you need is a working hard disk.
Just install it in the snap server, then fire up a web browser, goto the snapserver webpage, enter administrator mode, then configure the new disk.

redyug 09-06-2013 09:34 AM

Re: Snap Server 12000
Haven't been active in this forum for a while. I've been busy. I'm not a guru. I own a 12000, a 2000 and two 14000 servers. One thing that I noticed people forget when they have problems is hardware. If your server doesn't connect, the ethernet card could be bad. Very cheap to replace too. My older 14000 wouldn't connect, and its second card was to blame. I pulled the card, it connected with only the single connection. $10 replacement on the way. For me it was an Intel Pro 1000 XT, but the 12000 uses the Intel Pro 1000 T. For reference sake, I swapped the 12000's card with the bad one in the 14000, and it worked fine, so I know it was the card. As for the reset process (USE CAUTION) in the 12000 or 14000, hold down the middle button under the display while you hit power and continue to hold it until it says 'Maintenance Mode.' You get 4 options unless options 5 & 6 are enabled. TRY NOT TO USE OPTION 4 - DESTRUCTIVE.
Option 1 on maintenance mode clears the password. Option 2 clears the ip address. Option 3 clears both the password and ip as well as resets almost all settings and enables DHCP if it wasn't enabled already. Option 4 is DESTRUCTIVE as it resets everything including the drive assignments and you cannot recover your data unless you have a disaster recovery image prepared before you used this option. Option 5 & 6 are reserved for tech use and are not usually available unless all drives are removed or you've previously used done option 4 I think? Option five enables a utility to update the flash chip and displays an address. ( "Waiting for update, I am") Option 6 suppresses file system for whatever good that does. I guess it might be useful if your consoles hangs, but you would only be able to access the server with a 9 pin null modem cable connected to a computer using hyperterminal and very specific commands. Such a connection shouldn't necessary, unless your flash is corrupt or worse. One other option is a crossover ethernet cable that just basically lets you connect directly with a laptop or nearby computer directly without the need of a network, but it might not work if there is a pre-existing network connection problem. Hope this helps someone.

All times are GMT -5. The time now is 11:22 AM.

Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
(C) 2005
If we in some way offend you, insult you or your people, screw your mom, beat up your dad, or poop on your porch... we're sorry... we were probably really drunk...
Oh and dont steal our content bitches! Don't give us a reason to pee in your open car window this summer...